summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorThierry Reding <treding@nvidia.com>2018-03-28 14:04:32 +0200
committerAdam Jackson <ajax@redhat.com>2018-03-28 09:54:14 -0400
commit66402fcd8280b393d3992121c0bcff9c646c97ed (patch)
treef6bf8f69b83b7b868532094f7e877e923fbb444f /meson.build
parent0a7dabc86c1a7b8d91a5d22ad12fbf03d859f43e (diff)
meson: Fix build if Xdmcp is missing
Xdmcp is an optional dependency, so make sure the build succeeds if it is missing. Signed-off-by: Thierry Reding <treding@nvidia.com> Reviewed-by: Adam Jackson <ajax@redhat.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build8
1 files changed, 7 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index b39c47e81..900176e41 100644
--- a/meson.build
+++ b/meson.build
@@ -288,11 +288,17 @@ endif
# XXX: Add more sha1 options, because Linux is about choice
sha1_dep = nettle_dep
-xdmcp_dep = []
+xdmcp_dep = dependency('', required : false)
if get_option('xdmcp')
xdmcp_dep = dependency('xdmcp')
endif
+has_xdm_auth = get_option('xdm-auth-1')
+
+if not xdmcp_dep.found()
+ has_xdm_auth = false
+endif
+
build_glx = get_option('glx')
libdrm_dep = dependency('libdrm', version: '>= 2.4.89', required: false)