summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorLaurent Carlier <lordheavym@gmail.com>2018-03-01 12:55:11 +0100
committerAdam Jackson <ajax@redhat.com>2018-03-02 12:05:42 -0500
commit238219e7312e2b5d972a8620b02379009686a005 (patch)
tree4fb335ec6be28ab2c7e783c2f6ece40744e16de9 /meson.build
parent2af0a50a4bb9be9f58681d417ceb9a7029caaf3b (diff)
meson: Make APM support optional
v2: Define HAVE_APM in dix-config.h Signed-off-by: Laurent Carlier <lordheavym@gmail.com> Reviewed-by: Adam Jackson <ajax@redhat.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build9
1 files changed, 8 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 4748724e3..6a671587e 100644
--- a/meson.build
+++ b/meson.build
@@ -369,8 +369,15 @@ elif get_option('dga') == 'true'
build_dga = true
endif
-# XXX: Allow configuration of these.
build_apm = false
+if (get_option('linux_apm') == true and
+ host_machine.system() == 'linux')
+ if cc.has_header('linux/apm_bios.h')
+ build_apm = true
+ endif
+endif
+
+# XXX: Allow configuration of these.
build_acpi = false
build_mitshm = true
build_xselinux = false