summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorKeith Packard <keithp@keithp.com>2018-03-02 17:05:04 -0800
committerAdam Jackson <ajax@redhat.com>2018-03-05 11:45:57 -0500
commit0ff4074224ea370e021d79526c63cef91356730d (patch)
treef6668a2524366d340e3b559f4200b227f3236c37 /meson.build
parent43ffd572592d26bb78decfdf55e643bdfb011d3f (diff)
Require libdrm 2.4.89 or newer
Both autotools and meson build systems had complicated logic around what version of libdrm to require for various options. Remove that and just check for a new enough version to support all of the options which need libdrm. Signed-off-by: Keith Packard <keithp@keithp.com> Reviewed-by: Adam Jackson <ajax@redhat.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build12
1 files changed, 2 insertions, 10 deletions
diff --git a/meson.build b/meson.build
index c66a2501c..430c770cb 100644
--- a/meson.build
+++ b/meson.build
@@ -301,16 +301,8 @@ else
endif
libdrm_required = (get_option('dri1') == 'true') or (get_option('dri2') == 'true') or (get_option('dri3') == 'true')
-libdrm_dep = dependency('libdrm', version: '>= 2.3.1', required: libdrm_required)
-build_modesetting = false
-if libdrm_dep.found()
- if build_dri2
- # 2.4.65 is required for drmGetDevice
- dependency('libdrm', version: '>= 2.4.65')
- endif
- # 2.4.46 is required for cursor hotspot support.
- build_modesetting = libdrm_dep.version().version_compare('>= 2.4.46')
-endif
+libdrm_dep = dependency('libdrm', version: '>= 2.4.89', required: libdrm_required)
+build_modesetting = libdrm_dep.found()
build_vbe = false
if get_option('vbe') == 'auto'