summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAndreas Boll <andreas.boll.dev@gmail.com>2013-02-01 13:39:42 +0100
committerChad Versace <chad.versace@linux.intel.com>2013-04-23 03:16:10 +0200
commit723b78397fbad8987e14b7bb2376055529f40856 (patch)
tree8b456bcdd8f94b69e586d4e7ab2eea5f76f31d8d /configure.ac
parent7be536bb19f005331525410271cc98cd356102fd (diff)
configure.ac: Allow OpenGL ES1 and ES2 only with enabled OpenGL
Building OpenGL ES1 and/or ES2 without OpenGL is not supported on mesa 9.0.x Reviewed-by: Chad Versace <chad.versace@linux.intel.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 50e60f623b..06d9fc9f0b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -676,6 +676,17 @@ if test "x$enable_opengl" = xno -a \
AC_MSG_ERROR([at least one API should be enabled])
fi
+# Building OpenGL ES1 and/or ES2 without OpenGL is not supported on mesa 9.0.x
+if test "x$enable_opengl" = xno -a \
+ "x$enable_gles1" = xyes; then
+ AC_MSG_ERROR([Building OpenGL ES1 without OpenGL is not supported])
+fi
+
+if test "x$enable_opengl" = xno -a \
+ "x$enable_gles2" = xyes; then
+ AC_MSG_ERROR([Building OpenGL ES2 without OpenGL is not supported])
+fi
+
API_DEFINES=""
if test "x$enable_opengl" = xno; then
API_DEFINES="$API_DEFINES -DFEATURE_GL=0"