summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNiels Ole Salscheider <niels_ole@salscheider-online.de>2013-08-07 17:48:48 +0200
committerTom Stellard <thomas.stellard@amd.com>2013-08-16 16:52:31 -0700
commit5394ee8f30452ae201b1e35e579aa6edcd991cee (patch)
tree0351592d6fda12e47ff0ab663e7d8ac55bed95af /configure.ac
parent21d9a1b5ef51ce449e9a82641d0d605c5448b41c (diff)
clover: Fix linkage of libOpenCL
Clover needs the option component of llvm. Reviewed-by: Tom Stellard <tom@stellard.net> Signed-off-by: Niels Ole Salscheider <niels_ole@salscheider-online.de>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 62d06e0357..0dcd2a51f9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1617,6 +1617,10 @@ if test "x$enable_gallium_llvm" = xyes; then
if $LLVM_CONFIG --components | grep -qw 'irreader'; then
LLVM_COMPONENTS="${LLVM_COMPONENTS} irreader"
fi
+ # LLVM 3.4 requires Option
+ if $LLVM_CONFIG --components | grep -qw 'option'; then
+ LLVM_COMPONENTS="${LLVM_COMPONENTS} option"
+ fi
fi
DEFINES="${DEFINES} -DHAVE_LLVM=0x0$LLVM_VERSION_INT"
MESA_LLVM=1