summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJose Fonseca <jfonseca@vmware.com>2015-03-04 21:14:10 +0000
committerJose Fonseca <jfonseca@vmware.com>2016-01-26 11:14:05 +0000
commit3bd6dce5b0d1f0438ff6528d5fe6e317ae5d2ea9 (patch)
tree5f3a1593b014d0c5bb31a054191addee74936fef /CMakeLists.txt
parent096e4bdb8621edec69fb01923ac56803187cb57a (diff)
cmake: Simplify logic for MSVC 2013 U4.
Matches Waffle's https://github.com/waffle-gl/waffle/commit/d15a83a453c87b445d8abf19d82668bca1a389d4 Trivial.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 2 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 2da1e6f74..493cece61 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -18,10 +18,8 @@ endif()
project (piglit)
# Require MSVC 2013 U4
-if (MSVC)
- if (${CMAKE_C_COMPILER_VERSION} VERSION_LESS 18.00.31101.0)
- message (FATAL_ERROR "Visual Studio 2013 Update 4 or later required")
- endif ()
+if (MSVC AND CMAKE_C_COMPILER_VERSION VERSION_LESS 18.00.31101.0)
+ message (FATAL_ERROR "Visual Studio 2013 Update 4 or later required")
endif ()
find_package(Threads)