summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDylan Baker <baker.dylan.c@gmail.com>2015-02-19 14:47:37 -0800
committerDylan Baker <baker.dylan.c@gmail.com>2015-02-23 15:47:09 -0800
commit3780c734874aab862f068d9d2dc23d249b3217f5 (patch)
tree0252792141c4f7d2778a490b7a3691b4d56fe274 /CMakeLists.txt
parentc4585427913e4cb28994b4bfb11d49778273aa2c (diff)
Add dependency on Python six
Six is a module that provides a clean, standardized interface for handling python2 and python3 from the same code base. This adds a requirement on six as a build-time dependency, the plan is to use it only for python generators (those called during build time) While it certainly is possible to reimplement much of what six does scratch and not add another python dependency, I think it's better to just use six. For one thing a large number of python modules already depend on six, so the chances are good that most people already have it installed. Second, it's the de facto standard for supporting complex code bases in 2 and 3, so it's familiar and many of the corner cases have already been addressed. This adds the necessary cmake boilerplate to ensure that six is available. At this time I don't know of a specific version being required, but I am currently using 1.9.0 v2: - update README with six dependency (Jordan) Signed-off-by: Dylan Baker <dylanx.c.baker@intel.com> Reviewed-by: Jordan Justen <jordan.l.justen@intel.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index db5f718d9..1a81eed27 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -192,6 +192,7 @@ ENDIF()
find_package(PythonInterp 2.7 REQUIRED)
find_package(PythonNumpy 1.6.2 REQUIRED)
find_package(PythonMako 0.7.3 REQUIRED)
+find_package(PythonSix REQUIRED)
# Default to compiling with debug information (`gcc -g`):
if(NOT CMAKE_BUILD_TYPE)