summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJustin Bogner <mail@justinbogner.com>2015-03-25 08:07:47 +0000
committerJustin Bogner <mail@justinbogner.com>2015-03-25 08:07:47 +0000
commitc0ffe0f06130f3f8d7bc3660f1a5979dcdb67624 (patch)
treedbbc05405b49ae344adf308853494abfffa6702b /CMakeLists.txt
parent544763dcba41e5843ac3de21a66cd1f39bcf636a (diff)
test: Fix the dependencies for the check-llvm-* targets
In r233009 we gained specific check-llvm-* build targets for invoking specific parts of the test suite, but they were copying the dependencies for check-all, rather than just listing the dependencies for check-llvm. This moves the creation of these targets next to the check-llvm target, and uses that target's configuration rather than the check-all config. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@233174 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 0 insertions, 5 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ea3fda39c37..bef66ec4774 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -631,11 +631,6 @@ if( LLVM_INCLUDE_TESTS )
DEPENDS ${LLVM_LIT_DEPENDS}
ARGS ${LLVM_LIT_EXTRA_ARGS}
)
-
- add_lit_testsuites(LLVM ${CMAKE_SOURCE_DIR}/test
- PARAMS ${LLVM_LIT_PARAMS}
- DEPENDS ${LLVM_LIT_DEPENDS}
- ARGS ${LLVM_LIT_EXTRA_ARGS})
endif()
if (LLVM_INCLUDE_DOCS)