summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDouglas Katzman <dougk@google.com>2015-07-28 14:43:53 +0000
committerDouglas Katzman <dougk@google.com>2015-07-28 14:43:53 +0000
commit8d1cf2218d1d03171a4716816196975959aceb5f (patch)
tree456f005b5acebfe7af2944bc9576aa68ca2c304b /CMakeLists.txt
parentc26dfdf86b442404ed2a3d209fd152e6be0f53a1 (diff)
Use a specified list of languages in cmake project() command.
This allows asm files and Cxx files to be compiled with different flags rather than treating them identically. LLVM itself has no asm files other than tests, but this setting is inherited by the compiler-rt project (unless compiled standalone), which does have asm files. Differential Revision: http://reviews.llvm.org/D10707 git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@243419 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 2901257ea8b..b22efdf8cf4 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -26,7 +26,7 @@ else()
set(cmake_3_2_USES_TERMINAL USES_TERMINAL)
endif()
-project(LLVM)
+project(LLVM C CXX ASM)
# The following only works with the Ninja generator in CMake >= 3.0.
set(LLVM_PARALLEL_COMPILE_JOBS "" CACHE STRING