summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorDylan Baker <dylan@pnwbakers.com>2018-10-01 12:40:34 -0700
committerDylan Baker <dylan@pnwbakers.com>2018-10-10 11:02:36 -0700
commitb8521704ed2f5e84f0599a040c015ef02890468d (patch)
tree694b1717bd579105f36d1aaf828b0f19dda22d6f /meson.build
parent0346ad37741b11d640c1c4970b275c1f0c7f9e75 (diff)
meson: Don't allow building EGL on Windows or MacOS
Currently mesa only supports EGL on Unix like systems, cygwin, and haiku. Meson should actually enforce this. This fixes the default build on MacOS. v2: - invert the condition, mark darwin and windows as not supported instead of trying to mark what is supported. v3: - add missing ) v3: - Update comment to reflect condition change in v2 CC: 18.2 <mesa-stable@lists.freedesktop.org> Reviewed-by: Eric Engestrom <eric.engestrom@intel.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build7
1 files changed, 6 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index e4b9f04949c..002ce35a608 100644
--- a/meson.build
+++ b/meson.build
@@ -306,7 +306,10 @@ endif
_egl = get_option('egl')
if _egl == 'auto'
- with_egl = with_dri and with_shared_glapi and with_platforms
+ with_egl = (
+ not ['darwin', 'windows'].contains(host_machine.system()) and
+ with_dri and with_shared_glapi and with_platforms
+ )
elif _egl == 'true'
if not with_dri
error('EGL requires dri')
@@ -316,6 +319,8 @@ elif _egl == 'true'
error('No platforms specified, consider -Dplatforms=drm,x11,surfaceless at least')
elif not ['disabled', 'dri'].contains(with_glx)
error('EGL requires dri, but a GLX is being built without dri')
+ elif ['darwin', 'windows'].contains(host_machine.system())
+ error('EGL is not available on Windows or MacOS')
endif
with_egl = true
else