summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorChristoph Haag <christoph.haag@collabora.com>2018-09-18 01:08:07 +0200
committerDylan Baker <dylan@pnwbakers.com>2018-09-20 06:08:50 -0700
commitb01834b56c2b0da4366ec4e780e1d1bc7246c6eb (patch)
tree641f7973f7be7a91757f396c58c07041b38ddfe9 /meson.build
parent0abce6d7700ee42eb00c787732ec1fdefe250d03 (diff)
meson: add option to statically link llvm
Reviewed-by: Dylan Baker <dylan@pnwbakers.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 4 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 0588ebf8e7a..5e250470ed1 100644
--- a/meson.build
+++ b/meson.build
@@ -1188,6 +1188,8 @@ else
_llvm_version = '>= 3.3.0'
endif
+_shared_llvm = get_option('shared-llvm')
+
_llvm = get_option('llvm')
if _llvm == 'auto'
dep_llvm = dependency(
@@ -1196,6 +1198,7 @@ if _llvm == 'auto'
modules : llvm_modules,
optional_modules : llvm_optional_modules,
required : with_amd_vk or with_gallium_radeonsi or with_gallium_swr or with_gallium_opencl,
+ static : not _shared_llvm
)
with_llvm = dep_llvm.found()
elif _llvm == 'true'
@@ -1204,6 +1207,7 @@ elif _llvm == 'true'
version : _llvm_version,
modules : llvm_modules,
optional_modules : llvm_optional_modules,
+ static : not _shared_llvm,
)
with_llvm = true
else