summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorJon Turney <jon.turney@dronecode.org.uk>2018-01-15 19:39:46 +0000
committerJon Turney <jon.turney@dronecode.org.uk>2018-07-05 17:48:35 +0100
commitab7aa0f10cad31c79fc2ae519733564e1557478a (patch)
tree806f90ae5af7568601f580e2a27a9f5f04c4ae5c /meson.build
parent72fd93370fe993871c66300a6eb61fb69038fc8f (diff)
meson: Set with_dri from with_gallium when DRI glx is explicitly configured
Set with_dri from with_gallium when DRI GLX is explicitly configured, as well as when DRI GLX is chosen automatically. Signed-off-by: Jon Turney <jon.turney@dronecode.org.uk> Reviewed-by: Dylan Baker <dylan@pnwbakers.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 5 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index b2722c71e5b..7d12af3d510 100644
--- a/meson.build
+++ b/meson.build
@@ -263,7 +263,6 @@ if with_glx == 'auto'
elif with_gallium
# Even when building just gallium drivers the user probably wants dri
with_glx = 'dri'
- with_dri = true
elif with_platform_x11 and with_any_opengl and not with_any_vk
# The automatic behavior should not be to turn on xlib based glx when
# building only vulkan drivers
@@ -272,6 +271,11 @@ if with_glx == 'auto'
with_glx = 'disabled'
endif
endif
+if with_glx == 'dri'
+ if with_gallium
+ with_dri = true
+ endif
+endif
if not (with_dri or with_gallium or with_glx == 'xlib' or with_glx == 'gallium-xlib')
with_gles1 = false