summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorEmil Velikov <emil.velikov@collabora.com>2018-08-16 13:59:38 +0100
committerEmil Velikov <emil.l.velikov@gmail.com>2018-08-23 17:00:13 +0100
commitae7898dfdbe5c8dab7d11c71862353f1ae43feb0 (patch)
treedf2e6bbf52a4a9450f1306bf8344b049eb1fb71e /configure.ac
parentc51e7486d90a605b18109d5509fed0d3db23a8a5 (diff)
configure: allow building with python3
Pretty much all of the scripts are python2+3 compatible. Check and allow using python3, while adjusting the PYTHON2 refs. Note: - python3.4 is used as it's the earliest supported version - python3 chosen prior to python2 Signed-off-by: Emil Velikov <emil.velikov@collabora.com> Acked-by: Eric Engestrom <eric.engestrom@intel.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 3 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index f8bb131cb63..8dea87fa6a8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -125,9 +125,7 @@ AC_PROG_GREP
AC_PROG_NM
AM_PROG_AS
AX_CHECK_GNU_MAKE
-AM_PATH_PYTHON([2.7],, [:])
-PYTHON2=$PYTHON
-AC_SUBST([PYTHON2])
+AM_PATH_PYTHON([3.4],, [AM_PATH_PYTHON([2.7],, [:])])
AC_PROG_SED
AC_PROG_MKDIR_P
@@ -160,7 +158,7 @@ fi
AX_CHECK_PYTHON_MAKO_MODULE($PYTHON_MAKO_REQUIRED)
-if test "$PYTHON2" = ":"; then
+if test "$PYTHON" = ":"; then
if test ! -f "$srcdir/src/util/format_srgb.c"; then
AC_MSG_ERROR([Python not found - unable to generate sources])
fi
@@ -3348,7 +3346,7 @@ if test "x$enable_llvm" = xyes; then
echo " LLVM_LDFLAGS: $LLVM_LDFLAGS"
echo ""
fi
-echo " PYTHON2: $PYTHON2"
+echo " PYTHON: $PYTHON"
echo ""
echo " Run '${MAKE-make}' to build Mesa"