summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorSamuel Pitoiset <samuel.pitoiset@gmail.com>2019-11-22 12:16:50 +0100
committerSamuel Pitoiset <samuel.pitoiset@gmail.com>2019-11-25 07:51:56 +0000
commitd6db858771ab72f607e43cd2cacf73b2f62fad30 (patch)
treeba939ea1da47b1d05f3a4c4f2c30057646517292 /meson.build
parentbfb307aea922218cb72ffc9d977e88dfcadb2daf (diff)
meson: only build imgui when needed
Only required for Intel tools or the Vulkan overlay layer. Signed-off-by: Samuel Pitoiset <samuel.pitoiset@gmail.com> Reviewed-by: Eric Engestrom <eric.engestrom@intel.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 4 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 9585807fbee..e8bec9bb389 100644
--- a/meson.build
+++ b/meson.build
@@ -53,6 +53,7 @@ with_glx_read_only_text = get_option('glx-read-only-text')
with_glx_direct = get_option('glx-direct')
with_osmesa = get_option('osmesa')
with_swr_arches = get_option('swr-arches')
+with_vulkan_overlay_layer = get_option('vulkan-overlay-layer')
with_tools = get_option('tools')
if with_tools.contains('all')
with_tools = [
@@ -69,6 +70,9 @@ if with_tools.contains('all')
]
endif
+with_intel_tools = with_tools.contains('intel') or with_tools.contains('intel-ui')
+with_imgui = with_intel_tools or with_vulkan_overlay_layer
+
dri_drivers_path = get_option('dri-drivers-path')
if dri_drivers_path == ''
dri_drivers_path = join_paths(get_option('prefix'), get_option('libdir'), 'dri')