summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gmail.com>2017-03-06 10:20:10 -0800
committerMatt Turner <mattst88@gmail.com>2017-03-07 07:27:45 -0800
commit8a26e944399ae4d0fd662e5106f0b34f5ced462d (patch)
treef552aa224b4818ab952e234ffbd4e41f3089f341 /configure.ac
parentf73903f09bd53fe4659dc8771141a6466956123f (diff)
configure.ac: Use PKG_CHECK_VAR for wayland-scanner.
Available since pkg-config-0.28 and pkgconf-0.8.10. The removal of the AC_PATH_PROG is intentional. Use pkg-config. Reviewed-by: Emil Velikov <emil.velikov@collabora.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 1 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index 49cb28338d5..7a89344bed7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2102,12 +2102,7 @@ if test "x$with_egl_platforms" != "x" -a "x$enable_egl" != xyes; then
AC_MSG_ERROR([cannot build egl state tracker without EGL library])
fi
-PKG_CHECK_MODULES([WAYLAND_SCANNER], [wayland-scanner],
- WAYLAND_SCANNER=`$PKG_CONFIG --variable=wayland_scanner wayland-scanner`,
- WAYLAND_SCANNER='')
-if test "x$WAYLAND_SCANNER" = x; then
- AC_PATH_PROG([WAYLAND_SCANNER], [wayland-scanner])
-fi
+PKG_CHECK_VAR([WAYLAND_SCANNER], [wayland-scanner], [wayland_scanner])
# Do per-EGL platform setups and checks
egl_platforms=`IFS=', '; echo $with_egl_platforms`