summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMatthieu Herrb <matthieu.herrb@laas.fr>2012-01-02 13:23:59 +0000
committerKeith Packard <keithp@keithp.com>2012-01-09 13:09:49 -0800
commit6d6d4cb6043905d850834946e9bfc526ed5a9ef7 (patch)
tree3f556eb70349cb4b047d7f8066fdaa5fe5f02278 /configure.ac
parenta55214d11916b707b7c8c65c555cc0cbb59ac503 (diff)
Add OpenBSD support to DetermineClientCmd()
Uses kvm_getargv() from libkvm. Signed-off-by: Matthieu Herrb <matthieu.herrb@laas.fr> Reviewed-by: Adam Jackson <ajax@redhat.com> Signed-off-by: Keith Packard <keithp@keithp.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 6de92b435..8fafb2e37 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1024,6 +1024,13 @@ if test "x$RES" = xyes && test "x$CLIENTIDS" = xyes; then
else
CLIENTIDS=no
fi
+if test "x$CLIENTIDS" = xyes; then
+ case $host_os in
+ openbsd*)
+ SYS_LIBS="$SYS_LIBS -lkvm"
+ ;;
+ esac
+fi
AC_MSG_RESULT([$CLIENTIDS])
AM_CONDITIONAL(CLIENTIDS, [test "x$CLIENTIDS" = xyes])