summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am26
1 files changed, 13 insertions, 13 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 6d9cfeb..3a0188d 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -1,20 +1,20 @@
NULL =
noinst_PROGRAMS =
-TESTS = coroutine \
- util \
- session \
+TESTS = test-coroutine \
+ test-util \
+ test-session \
test-spice-uri \
test-file-transfer \
$(NULL)
if WITH_PHODAV
-TESTS += pipe
+TESTS += test-pipe
endif
if WITH_POLKIT
-TESTS += usb-acl-helper
-noinst_PROGRAMS += mock-acl-helper
+TESTS += test-usb-acl-helper
+noinst_PROGRAMS += test-mock-acl-helper
endif
noinst_PROGRAMS += $(TESTS)
@@ -34,14 +34,14 @@ LDADD = \
$(top_builddir)/src/libspice-client-glib-2.0.la \
$(NULL)
-util_SOURCES = util.c
-coroutine_SOURCES = coroutine.c
-session_SOURCES = session.c
-pipe_SOURCES = pipe.c
+test_util_SOURCES = util.c
+test_coroutine_SOURCES = coroutine.c
+test_session_SOURCES = session.c
+test_pipe_SOURCES = pipe.c
test_spice_uri_SOURCES = uri.c
test_file_transfer_SOURCES = file-transfer.c
-usb_acl_helper_SOURCES = usb-acl-helper.c
-usb_acl_helper_CFLAGS = -DTESTDIR=\"$(abs_builddir)\"
-mock_acl_helper_SOURCES = mock-acl-helper.c
+test_usb_acl_helper_SOURCES = usb-acl-helper.c
+test_usb_acl_helper_CFLAGS = -DTESTDIR=\"$(abs_builddir)\"
+test_mock_acl_helper_SOURCES = mock-acl-helper.c
-include $(top_srcdir)/git.mk