summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorFabiano FidĂȘncio <fidencio@redhat.com>2015-01-06 01:46:50 +0100
committerFabiano FidĂȘncio <fidencio@redhat.com>2015-01-06 15:27:09 +0100
commite48fda77d713738c616e4cd3acb4fdb5f874f6fb (patch)
tree1d67c3ff0d26cfd7357bcf7788c9615cc8525acc /configure.ac
parent5b252b0f499601bcf387c02a4dd35d27ed34c07c (diff)
audio: drop gst-0.10 in favour of gst-1.0
As gstreamer-1,0 support was introduced by commit d4d60c97 and it works pretty much as gstreamer-0,10 used to work (tests were made both on Linux and Windows clients), let's drop the old gstreamer-0.10 support in favour of gstreamer-1.0.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac21
1 files changed, 5 insertions, 16 deletions
diff --git a/configure.ac b/configure.ac
index b55f3a0..9b420a3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -285,7 +285,7 @@ AS_IF([test "x$have_phodav" = "xyes"],
AC_DEFINE([USE_PHODAV], [1], [Define if supporting phodav]))
AC_ARG_WITH([audio],
- AS_HELP_STRING([--with-audio=@<:@gstreamer/gstreamer1/pulse/auto/no@:>@], [Select audio backend @<:@default=auto@:>@]),
+ AS_HELP_STRING([--with-audio=@<:@gstreamer/pulse/auto/no@:>@], [Select audio backend @<:@default=auto@:>@]),
[],
[with_audio="auto"])
@@ -294,7 +294,7 @@ AS_IF([test "x$with_audio" = "xauto"], [
])
case "$with_audio" in
- gstreamer|gstreamer1|pulse|no*)
+ gstreamer|pulse|no*)
;;
*) AC_MSG_ERROR(Unsupported audio backend)
esac
@@ -314,27 +314,16 @@ AC_SUBST(PULSE_CFLAGS)
AC_SUBST(PULSE_LIBS)
AS_IF([test "x$with_audio" = "xgstreamer"],
- [PKG_CHECK_MODULES(GST, gstreamer-0.10 gstreamer-base-0.10 gstreamer-app-0.10 gstreamer-audio-0.10, [have_gst=yes], [have_gst=no])],
+ [PKG_CHECK_MODULES(GST, gstreamer-1.0 gstreamer-base-1.0 gstreamer-app-1.0 gstreamer-audio-1.0, [have_gst=yes], [have_gst=no])],
[have_gst=no])
AS_IF([test "x$have_gst" = "xyes"],
- [AC_DEFINE([WITH_GSTAUDIO], 1, [Have GStreamer?])],
+ [AC_DEFINE([WITH_GSTAUDIO], 1, [Have GStreamer 1.0?])],
[AS_IF([test "x$with_audio" = "xgstreamer"],
- [AC_MSG_ERROR([GStreamer requested but not found])
- ])
-])
-
-AS_IF([test "x$with_audio" = "xgstreamer1"],
- [PKG_CHECK_MODULES(GST, gstreamer-1.0 gstreamer-base-1.0 gstreamer-app-1.0 gstreamer-audio-1.0, [have_gst1=yes], [have_gst1=no])],
- [have_gst1=no])
-
-AS_IF([test "x$have_gst1" = "xyes"],
- [AC_DEFINE([WITH_GST1AUDIO], 1, [Have GStreamer 1.0?])],
- [AS_IF([test "x$with_audio" = "xgstreamer1"],
[AC_MSG_ERROR([GStreamer 1.0 requested but not found])
])
])
-AM_CONDITIONAL([WITH_GSTAUDIO], [test "x$have_gst" = "xyes" -o "x$have_gst1" = "xyes"])
+AM_CONDITIONAL([WITH_GSTAUDIO], [test "x$have_gst" = "xyes"])
AC_SUBST(GST_CFLAGS)
AC_SUBST(GST_LIBS)