summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorMarc-André Lureau <marcandre.lureau@redhat.com>2012-01-15 20:38:22 +0100
committerMarc-André Lureau <marcandre.lureau@redhat.com>2012-01-15 22:07:05 +0100
commitc5093cf7d50abe3759def01073cf6fef6630a4a0 (patch)
treef4cf625b11f0e854163f67850cad8d88f7b11ff0 /Makefile.am
parent8c6e1441795cfcbcd5778cf2006afeac187e3b22 (diff)
Generate ChangeLog and ship it in the tarball
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am12
1 files changed, 11 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 48b7b46..8136550 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -55,8 +55,18 @@ MAINTAINERCLEANFILES = \
po/Makefile.in.in \
$(NULL)
+# Generate the ChangeLog file (with all entries since the switch to git)
+# and insert it into the directory we're about to use to create a tarball.
+.PHONY: gen-ChangeLog
+gen-ChangeLog:
+ if test -d .git || test -d ../.git; then \
+ $(top_srcdir)/build-aux/gitlog-to-changelog > $(distdir)/cl-t; \
+ rm -f $(distdir)/ChangeLog; \
+ mv $(distdir)/cl-t $(distdir)/ChangeLog; \
+ fi
+
# see git-version-gen
-dist-hook:
+dist-hook: gen-ChangeLog
echo $(VERSION) > $(distdir)/.tarball-version
BUILT_SOURCES = $(top_srcdir)/.version