summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBeniamino Galvani <bgalvani@redhat.com>2018-09-07 16:53:40 +0200
committerBeniamino Galvani <bgalvani@redhat.com>2018-09-13 14:35:13 +0200
commitd6e787d4c5d89c226b7c7f16f53753ca874e20e1 (patch)
tree5c65e32e8ab6395fe6f49e885439c1e1b5d1e8ca /configure.ac
parentbf6859f0756a1e7d3add7ddd84de31b6dd1decf6 (diff)
build: remove check on dhclient version
dhclient 4.0 was released more than 10 years ago. I think it is reasonable to expect that nobody is using an older version today. https://source.isc.org/cgi-bin/gitweb.cgi?p=dhcp.git;a=shortlog;h=refs/tags/v4_0_0 (cherry picked from commit 9e61ea70402b5d8140de512bdcf84252fcb0d11c)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 1 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index 67b1ecd6f..e9d2fa97c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -842,7 +842,7 @@ AM_CONDITIONAL(WITH_OPENVSWITCH, test "${enable_ovs}" = "yes")
# DHCP client support
AC_ARG_WITH([dhclient],
- AS_HELP_STRING([--with-dhclient=yes|no|path], [Enable dhclient 4.x support]))
+ AS_HELP_STRING([--with-dhclient=yes|no|path], [Enable dhclient support]))
if test "$with_dhclient" != "no"; then
with_dhclient_="$with_dhclient"
AC_PATH_PROGS(with_dhclient, dhclient, no, /sbin:/usr/sbin:/usr/local/sbin)
@@ -851,10 +851,6 @@ if test "$with_dhclient" != "no"; then
AC_MSG_WARN([dhclient not found, assume path /usr/sbin/dhclient])
with_dhclient=/usr/sbin/dhclient
fi
- else
- if ! $with_dhclient --version 2>&1 | grep -q "^isc-dhclient-4\."; then
- AC_MSG_WARN([Seems version of dhclient $with_dhclient is too old, version 4.x or newer is required.])
- fi
fi
fi
if test "$with_dhclient" != "no"; then