summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Biebl <biebl@debian.org>2015-08-28 01:14:45 +0200
committerMichael Biebl <biebl@debian.org>2015-08-28 01:14:45 +0200
commit9f136cdf39f073a5c7db2901f8c34908ee48ad63 (patch)
treef2864662dc7539739e6d45281d52af5446bebb81
parente74d9a3e42f8967df5bfe21544b03f6b1e328277 (diff)
Refresh patches.
-rw-r--r--debian/changelog1
-rw-r--r--debian/patches/Don-t-setup-Sleep-Monitor-if-not-booted-with-systemd.patch2
-rw-r--r--debian/patches/Force-online-state-with-unmanaged-devices.patch20
-rw-r--r--debian/patches/Mark-virtual-ethernet-interfaces-as-unmanaged.patch6
-rw-r--r--debian/patches/Use-symlinks-for-nmtui.patch2
-rw-r--r--debian/patches/fix-arping-path.patch4
6 files changed, 18 insertions, 17 deletions
diff --git a/debian/changelog b/debian/changelog
index d2fdffb69..8ba8dc109 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,6 +1,7 @@
network-manager (1.0.6-1) UNRELEASED; urgency=medium
* New upstream release.
+ * Refresh patches.
-- Michael Biebl <biebl@debian.org> Fri, 28 Aug 2015 01:14:04 +0200
diff --git a/debian/patches/Don-t-setup-Sleep-Monitor-if-not-booted-with-systemd.patch b/debian/patches/Don-t-setup-Sleep-Monitor-if-not-booted-with-systemd.patch
index 7840dc741..1b57943b8 100644
--- a/debian/patches/Don-t-setup-Sleep-Monitor-if-not-booted-with-systemd.patch
+++ b/debian/patches/Don-t-setup-Sleep-Monitor-if-not-booted-with-systemd.patch
@@ -18,7 +18,7 @@ Closes: #742933
3 files changed, 9 insertions(+), 1 deletion(-)
diff --git a/configure.ac b/configure.ac
-index 381b621..13cf1b3 100644
+index 74dacb6..cf4ec63 100644
--- a/configure.ac
+++ b/configure.ac
@@ -384,8 +384,9 @@ fi
diff --git a/debian/patches/Force-online-state-with-unmanaged-devices.patch b/debian/patches/Force-online-state-with-unmanaged-devices.patch
index 451e5bd1c..7059973ac 100644
--- a/debian/patches/Force-online-state-with-unmanaged-devices.patch
+++ b/debian/patches/Force-online-state-with-unmanaged-devices.patch
@@ -12,7 +12,7 @@ Bug-Debian: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=512286
1 file changed, 120 insertions(+)
diff --git a/src/nm-manager.c b/src/nm-manager.c
-index 080cdb8..be109d0 100644
+index 34ec081..976b57f 100644
--- a/src/nm-manager.c
+++ b/src/nm-manager.c
@@ -62,6 +62,8 @@
@@ -35,7 +35,7 @@ index 080cdb8..be109d0 100644
guint timestamp_update_id;
gboolean startup;
-@@ -657,6 +663,29 @@ find_best_device_state (NMManager *manager)
+@@ -659,6 +665,29 @@ find_best_device_state (NMManager *manager)
return best_state;
}
@@ -63,9 +63,9 @@ index 080cdb8..be109d0 100644
+}
+
static void
- nm_manager_update_state (NMManager *manager)
+ nm_manager_update_metered (NMManager *manager)
{
-@@ -674,6 +703,9 @@ nm_manager_update_state (NMManager *manager)
+@@ -700,6 +729,9 @@ nm_manager_update_state (NMManager *manager)
nm_connectivity_set_online (priv->connectivity, new_state >= NM_STATE_CONNECTED_LOCAL);
@@ -75,7 +75,7 @@ index 080cdb8..be109d0 100644
if (new_state == NM_STATE_CONNECTED_SITE) {
nm_connectivity_check_async (priv->connectivity,
checked_connectivity,
-@@ -4123,6 +4155,65 @@ impl_manager_check_connectivity (NMManager *manager,
+@@ -4160,6 +4192,65 @@ impl_manager_check_connectivity (NMManager *manager,
}
static void
@@ -141,8 +141,8 @@ index 080cdb8..be109d0 100644
start_factory (NMDeviceFactory *factory, gpointer user_data)
{
nm_device_factory_start (factory);
-@@ -4174,6 +4265,9 @@ nm_manager_start (NMManager *self)
- system_create_virtual_devices (self);
+@@ -4213,6 +4304,9 @@ nm_manager_start (NMManager *self)
+ priv->devices_inited = TRUE;
check_if_startup_complete (self);
+
@@ -151,7 +151,7 @@ index 080cdb8..be109d0 100644
}
void
-@@ -4877,6 +4971,22 @@ nm_manager_init (NMManager *manager)
+@@ -4920,6 +5014,22 @@ nm_manager_init (NMManager *manager)
KERNEL_FIRMWARE_DIR);
}
@@ -173,8 +173,8 @@ index 080cdb8..be109d0 100644
+
/* Update timestamps in active connections */
priv->timestamp_update_id = g_timeout_add_seconds (300, (GSourceFunc) periodic_update_active_connection_timestamps, manager);
- }
-@@ -5086,6 +5196,16 @@ dispose (GObject *object)
+
+@@ -5128,6 +5238,16 @@ dispose (GObject *object)
g_clear_object (&priv->fw_monitor);
}
diff --git a/debian/patches/Mark-virtual-ethernet-interfaces-as-unmanaged.patch b/debian/patches/Mark-virtual-ethernet-interfaces-as-unmanaged.patch
index 96cab841d..56fb1ee79 100644
--- a/debian/patches/Mark-virtual-ethernet-interfaces-as-unmanaged.patch
+++ b/debian/patches/Mark-virtual-ethernet-interfaces-as-unmanaged.patch
@@ -9,10 +9,10 @@ any virtual ethernet interfaces and mark them as unmanaged.
1 file changed, 41 insertions(+)
diff --git a/src/devices/nm-device-ethernet.c b/src/devices/nm-device-ethernet.c
-index af2cb8f..2980df3 100644
+index beb86e1..6148b8d 100644
--- a/src/devices/nm-device-ethernet.c
+++ b/src/devices/nm-device-ethernet.c
-@@ -239,6 +239,45 @@ out:
+@@ -241,6 +241,45 @@ out:
g_object_unref (dev);
}
@@ -58,7 +58,7 @@ index af2cb8f..2980df3 100644
static GObject*
constructor (GType type,
guint n_construct_params,
-@@ -261,6 +300,8 @@ constructor (GType type,
+@@ -263,6 +302,8 @@ constructor (GType type,
/* s390 stuff */
_update_s390_subchannels (NM_DEVICE_ETHERNET (object));
diff --git a/debian/patches/Use-symlinks-for-nmtui.patch b/debian/patches/Use-symlinks-for-nmtui.patch
index f05667b71..b472b65fe 100644
--- a/debian/patches/Use-symlinks-for-nmtui.patch
+++ b/debian/patches/Use-symlinks-for-nmtui.patch
@@ -22,7 +22,7 @@ index ad9335d..09f2700 100644
uninstall-hook:
diff --git a/configure.ac b/configure.ac
-index 13cf1b3..dc68ccd 100644
+index cf4ec63..bb1ff6c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -33,6 +33,8 @@ AM_PROG_CC_C_O
diff --git a/debian/patches/fix-arping-path.patch b/debian/patches/fix-arping-path.patch
index 4addfb404..6b6e1bce8 100644
--- a/debian/patches/fix-arping-path.patch
+++ b/debian/patches/fix-arping-path.patch
@@ -15,10 +15,10 @@ Closes: #755039
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/src/devices/nm-device.c b/src/devices/nm-device.c
-index c5d4c20..d77640c 100644
+index 5889582..4754e10 100644
--- a/src/devices/nm-device.c
+++ b/src/devices/nm-device.c
-@@ -5562,7 +5562,7 @@ send_arps (NMDevice *self, const char *mode_arg)
+@@ -5693,7 +5693,7 @@ send_arps (NMDevice *self, const char *mode_arg)
if (num == 0)
return;