summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Biebl <biebl@debian.org>2015-08-28 17:01:03 +0200
committerMichael Biebl <biebl@debian.org>2015-08-28 17:01:05 +0200
commit96ba6d5275208c2334b1e7e8e5d2a9299b43a033 (patch)
tree84fd3e38f70fc2036b899519d7feed5c717e5b6d
parent060f69e37c716721d69859e7b5b069ab68f33c7e (diff)
Fix command line parsing in nmcli
Patch cherry-picked from upstream Git.
-rw-r--r--debian/changelog1
-rw-r--r--debian/patches/config-bugfix-parse-commandline-options-into-correct.patch34
-rw-r--r--debian/patches/series1
3 files changed, 36 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 6401c6b9e..20c8587f9 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -8,6 +8,7 @@ network-manager (1.0.6-1) UNRELEASED; urgency=medium
mechanism now to mark virtual interfaces as unmanaged. (Closes: #794083)
* Use GnuTLS crypto API instead of gcrypt. Patch cherry-picked from upstream
Git. (Closes: #748675)
+ * Fix command line parsing in nmcli. Patch cherry-picked from upstream Git.
-- Michael Biebl <biebl@debian.org> Fri, 28 Aug 2015 01:14:04 +0200
diff --git a/debian/patches/config-bugfix-parse-commandline-options-into-correct.patch b/debian/patches/config-bugfix-parse-commandline-options-into-correct.patch
new file mode 100644
index 000000000..f9ecf21f7
--- /dev/null
+++ b/debian/patches/config-bugfix-parse-commandline-options-into-correct.patch
@@ -0,0 +1,34 @@
+From: =?utf-8?q?Ulrich_=C3=96lmann?= <u.oelmann@pengutronix.de>
+Date: Thu, 27 Aug 2015 22:18:55 +0200
+Subject: config: bugfix: parse commandline options into correct object
+MIME-Version: 1.0
+Content-Type: text/plain; charset="utf-8"
+Content-Transfer-Encoding: 8bit
+
+Config related commandline options should be parsed into a function argument but
+were instead parsed into an object with local scope. As a result none of them
+had any impact.
+
+Signed-off-by: Ulrich Ölmann <u.oelmann@pengutronix.de>
+
+Fixes: b4ad7434a87c165a77b615accbe1868a9df9221b
+
+https://mail.gnome.org/archives/networkmanager-list/2015-August/msg00033.html
+
+(cherry-picked from commit 8a22a98157f7f6773f3d1f295419569c6c880a47)
+---
+ src/main.c | 1 -
+ 1 file changed, 1 deletion(-)
+
+diff --git a/src/main.c b/src/main.c
+index 495262e..a9bc479 100644
+--- a/src/main.c
++++ b/src/main.c
+@@ -246,7 +246,6 @@ do_early_setup (int *argc, char **argv[], NMConfigCmdLineOptions *config_cli)
+ {NULL}
+ };
+
+- config_cli = nm_config_cmd_line_options_new ();
+ if (!nm_main_utils_early_setup ("NetworkManager",
+ argc,
+ argv,
diff --git a/debian/patches/series b/debian/patches/series
index df1d3cc3c..5d2059877 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -10,3 +10,4 @@ Don-t-make-NetworkManager-D-Bus-activatable.patch
Don-t-block-network.target-on-NetworkManager-wait-on.patch
Fix-iscsiadm-path.patch
crypto-only-use-gnutls-crypto-API-remove-libgcrypt-d.patch
+config-bugfix-parse-commandline-options-into-correct.patch