summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Biebl <biebl@debian.org>2015-03-31 07:05:08 +0200
committerMichael Biebl <biebl@debian.org>2015-03-31 07:05:42 +0200
commit3d302b55086b5929b4719c2663f11d48a6d3669e (patch)
tree6b2c28f1006278a8c7744574e3148ca39717cf3d
parente5b351239917dcb198990eb114ac8e226eec7f95 (diff)
Don't block network.target on NetworkManager-wait-online.service
While at it, add a few other minor fixes like the addition of Documentation or RemainAfterExit=yes.
-rw-r--r--debian/changelog3
-rw-r--r--debian/patches/0020-Don-t-block-network.target-on-NetworkManager-wait-on.patch57
-rw-r--r--debian/patches/series1
3 files changed, 61 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index fa07a6b9e..83dd74241 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -3,6 +3,9 @@ network-manager (0.9.10.0-7) UNRELEASED; urgency=medium
* Don't make NetworkManager D-Bus activatable. If the daemon has been
stopped manually, we don't want it to be autostarted by client requests.
(Closes: #760998)
+ * Don't block network.target on NetworkManager-wait-online.service. While at
+ it, add a few other minor fixes like the addition of Documentation or
+ RemainAfterExit=yes.
-- Michael Biebl <biebl@debian.org> Tue, 31 Mar 2015 06:58:04 +0200
diff --git a/debian/patches/0020-Don-t-block-network.target-on-NetworkManager-wait-on.patch b/debian/patches/0020-Don-t-block-network.target-on-NetworkManager-wait-on.patch
new file mode 100644
index 000000000..1ddb666db
--- /dev/null
+++ b/debian/patches/0020-Don-t-block-network.target-on-NetworkManager-wait-on.patch
@@ -0,0 +1,57 @@
+From: Michael Biebl <biebl@debian.org>
+Date: Sun, 29 Mar 2015 22:58:43 +0200
+Subject: Don't block network.target on NetworkManager-wait-online.service
+
+network.target is supposed to be a passive unit which is pulled in my
+the network management service.
+
+Also, we want NetworkManager-wait-online.service be hooked up in
+network-online.target, not multi-user.target.
+
+While at it, add a few other smaller fixes, like the addition of
+Documentation= and RemainAfterExit=yes
+
+http://www.freedesktop.org/wiki/Software/systemd/NetworkTarget/
+https://bugzilla.gnome.org/show_bug.cgi?id=746039
+---
+ data/Makefile.am | 4 ----
+ data/NetworkManager-wait-online.service.in | 7 ++++---
+ 2 files changed, 4 insertions(+), 7 deletions(-)
+
+diff --git a/data/Makefile.am b/data/Makefile.am
+index a7c8070..60443bf 100644
+--- a/data/Makefile.am
++++ b/data/Makefile.am
+@@ -18,10 +18,6 @@ endif
+
+ NetworkManager-dispatcher.service: NetworkManager-dispatcher.service.in
+ $(edit) $< >$@
+-
+-install-exec-local:
+- install -d $(DESTDIR)$(systemdsystemunitdir)/network-online.target.wants
+- ln -sf $(systemdsystemunitdir)/NetworkManager-wait-online.service $(DESTDIR)$(systemdsystemunitdir)/network-online.target.wants
+ endif
+
+ examplesdir = $(docdir)/examples
+diff --git a/data/NetworkManager-wait-online.service.in b/data/NetworkManager-wait-online.service.in
+index 6ad6942..1753d20 100644
+--- a/data/NetworkManager-wait-online.service.in
++++ b/data/NetworkManager-wait-online.service.in
+@@ -1,13 +1,14 @@
+ [Unit]
+ Description=Network Manager Wait Online
++Documentation=man:nm-online(1)
+ Requisite=NetworkManager.service
+ After=NetworkManager.service
+-Wants=network.target
+-Before=network.target network-online.target
++Before=network-online.target
+
+ [Service]
+ Type=oneshot
+ ExecStart=@bindir@/nm-online -s -q --timeout=30
++RemainAfterExit=yes
+
+ [Install]
+-WantedBy=multi-user.target
++WantedBy=network-online.target
diff --git a/debian/patches/series b/debian/patches/series
index 144476cf7..dec255023 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -17,3 +17,4 @@
0017-Check-at-runtime-whether-to-start-ModemManager.patch
0018-core-do-not-assert-when-a-device-is-enslaved-externa.patch
0019-Don-t-make-NetworkManager-D-Bus-activatable.patch
+0020-Don-t-block-network.target-on-NetworkManager-wait-on.patch