summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Biebl <biebl@debian.org>2015-05-06 18:20:01 +0200
committerMichael Biebl <biebl@debian.org>2015-05-06 18:20:07 +0200
commit364705ff799e3293eda3c9ccfe61a8d43bf7da7b (patch)
treef38e4789bca41efecb9004b79ca5f3892e30de3e
parent5796d2d6d32990f6e46b1b158546612c99ee8cd9 (diff)
Fix path to the iscsiadm binary in the ibft plugin
-rw-r--r--debian/changelog1
-rw-r--r--debian/patches/Fix-iscsiadm-path.patch23
-rw-r--r--debian/patches/series1
3 files changed, 25 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 7fa8899b0..17d10a3ad 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -5,6 +5,7 @@ network-manager (1.0.2-1) UNRELEASED; urgency=medium
* Rebase patches.
* Enable and install the ibft plugin. This plugin queries the 'iscsiadm'
tool and generates connections based on the firmware configuration.
+ * Fix path to the iscsiadm binary in the ibft plugin.
-- Michael Biebl <biebl@debian.org> Tue, 05 May 2015 17:49:16 +0200
diff --git a/debian/patches/Fix-iscsiadm-path.patch b/debian/patches/Fix-iscsiadm-path.patch
new file mode 100644
index 000000000..161b366f0
--- /dev/null
+++ b/debian/patches/Fix-iscsiadm-path.patch
@@ -0,0 +1,23 @@
+From: Michael Biebl <biebl@debian.org>
+Date: Wed, 6 May 2015 18:17:51 +0200
+Subject: Fix iscsiadm path
+
+The open-scsi package in Debian installs the iscisadm binary as
+/usr/bin/iscsiadm.
+---
+ src/settings/plugins/ibft/plugin.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/settings/plugins/ibft/plugin.c b/src/settings/plugins/ibft/plugin.c
+index 632c4df..e64bbe4 100644
+--- a/src/settings/plugins/ibft/plugin.c
++++ b/src/settings/plugins/ibft/plugin.c
+@@ -62,7 +62,7 @@ read_connections (SCPluginIbft *self)
+ GError *error = NULL;
+ NMIbftConnection *connection;
+
+- if (!read_ibft_blocks ("/sbin/iscsiadm", &blocks, &error)) {
++ if (!read_ibft_blocks ("/usr/bin/iscsiadm", &blocks, &error)) {
+ nm_log_dbg (LOGD_SETTINGS, "ibft: failed to read iscsiadm records: %s", error->message);
+ g_error_free (error);
+ return;
diff --git a/debian/patches/series b/debian/patches/series
index a6227112c..1a072f1d0 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -9,3 +9,4 @@ Check-at-runtime-whether-to-start-ModemManager.patch
build-install-nm-settings-ifcfg-rh.5-man-page-condit.patch
Don-t-make-NetworkManager-D-Bus-activatable.patch
Don-t-block-network.target-on-NetworkManager-wait-on.patch
+Fix-iscsiadm-path.patch