summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules28
1 files changed, 28 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 00000000..2fa57078
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,28 @@
+#!/usr/bin/make -f
+
+DEB_HOST_MULTIARCH ?= $(shell dpkg-architecture -qDEB_HOST_MULTIARCH)
+
+export DEB_LDFLAGS_MAINT_APPEND = -Wl,-z,defs -Wl,--as-needed
+
+%:
+ dh $@ --with autoreconf,gir
+
+override_dh_autoreconf:
+ dh_autoreconf --as-needed
+
+override_dh_auto_configure:
+ dh_auto_configure -- \
+ --libexecdir=/usr/lib/NetworkManager \
+ --disable-more-warnings \
+ --enable-introspection \
+ --with-wwan
+
+override_dh_install:
+ find debian/tmp -name '*.a' -delete
+ find debian/tmp -name '*.la' -delete
+ dh_install --fail-missing
+
+override_dh_auto_test:
+ifeq (, $(filter nocheck, $(DEB_BUILD_OPTIONS)))
+ make check || ( find . -name test-suite.log -exec cat {} \;; exit 1; )
+endif