summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorBrian Paul <brianp@vmware.com>2017-07-07 14:29:09 -0600
committerBrian Paul <brianp@vmware.com>2017-07-11 21:21:39 -0600
commite9ae0fb488cef88649359a5087344a76fbba751a (patch)
tree408a5568c660c4760f76a29223b1930f0184d185 /CMakeLists.txt
parentb50af79d527c4c946c16eae28e49c30a0ae050fa (diff)
wgl: initial check-in of wgl utility code and wgl sanity check program
Like the glx tests/utility code, but for wgl. Note, one must set the PIGLIT_PLATFORM env var to "wgl" before running Piglit. It looks like there's some Waffle work to look at before this can be made automatic.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a24ddbc4a..76288b954 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -179,6 +179,13 @@ ELSE()
option(PIGLIT_BUILD_GLX_TESTS "Build tests that require GLX" OFF)
ENDIF()
+IF(PIGLIT_HAS_WGL)
+ option(PIGLIT_BUILD_WGL_TESTS "Build tests that require WGL" ON)
+ELSE()
+ option(PIGLIT_BUILD_WGL_TESTS "Build tests that require WGL" OFF)
+ENDIF()
+
+
# Choose to build tests that use dma_buf.
#
# Piglit's dma_buf utilities require xcb-dri2 to gain DRM authentication.