summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJan Vesely <jan.vesely@rutgers.edu>2017-06-22 09:52:53 -0400
committerVinson Lee <vlee@freedesktop.org>2017-06-23 17:18:41 -0700
commit7b865be9d248d52c4fb994f9063bb393e36f1465 (patch)
treea079a6d8ecd4b1ead25f3df755a2e4fcd116aab9 /CMakeLists.txt
parent21db402eea024842c3cdaacf2c53720d7ac1f082 (diff)
cmake: bump gbm dependency to 17.1
c6e1dc5247 switched to use gbm_bo_get_offset and gbm_bo_get_stride_for_plane. These symbols were added in mesa 17.1. Since there is no alternative to using them, bump the gbm requirement to 17.1. Fixes: c6e1dc5247 "piglit_drm_dma_buf: fix GPU offsets and strides" Signed-off-by: Jan Vesely <jan.vesely@rutgers.edu> Tested-by: Vinson Lee <vlee@freedesktop.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt10
1 files changed, 4 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b4dfe4fcf..90d056b5a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -137,16 +137,14 @@ IF(${CMAKE_SYSTEM_NAME} MATCHES "Linux")
add_definitions(-DPIGLIT_HAS_GLX)
endif()
- pkg_check_modules(GBM QUIET gbm)
+ pkg_check_modules(GBM QUIET gbm>=17.1)
if(GBM_FOUND)
set(PIGLIT_HAS_GBM True)
add_definitions(-DPIGLIT_HAS_GBM)
set(CMAKE_REQUIRED_LIBRARIES ${CMAKE_REQUIRED_LIBRARIES} ${GBM_LIBRARIES})
- if (GBM_VERSION VERSION_EQUAL "12.1" OR GBM_VERSION VERSION_GREATER "12.1")
- CHECK_FUNCTION_EXISTS(gbm_bo_map PIGLIT_HAS_GBM_BO_MAP)
- if (PIGLIT_HAS_GBM_BO_MAP)
- add_definitions(-DPIGLIT_HAS_GBM_BO_MAP)
- endif()
+ CHECK_FUNCTION_EXISTS(gbm_bo_map PIGLIT_HAS_GBM_BO_MAP)
+ if (PIGLIT_HAS_GBM_BO_MAP)
+ add_definitions(-DPIGLIT_HAS_GBM_BO_MAP)
endif()
endif(GBM_FOUND)