summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDylan Baker <baker.dylan.c@gmail.com>2015-01-07 11:14:53 -0800
committerDylan Baker <baker.dylan.c@gmail.com>2015-01-07 11:14:53 -0800
commit4f43b7d92bcde17fd837e7764db82d6b04524758 (patch)
tree6bf5ea7a5108eacc908de8e90a8932012c4ec5cc /CMakeLists.txt
parent3f6ee9d53c89c305d4b41f30c7c0dc6b4eeffb08 (diff)
CMakeList.txt: Fix error message for missing python
We require python 2.7, but our error message still says that we require 2.6. Trivial. Signed-off-by: Dylan Baker <baker.dylan.c@gmail.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 6fb6c8a37..7a41ee6a4 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -187,7 +187,7 @@ IF(PIGLIT_BUILD_GLX_TESTS)
pkg_check_modules(GLPROTO REQUIRED glproto)
ENDIF()
-# Check for presence of Python 2.6 or greater.
+# Check for presence of Python 2.7 or greater.
foreach(python_cmd python2 python)
execute_process(
COMMAND ${python_cmd} -c "import sys; assert '2.7' <= sys.version < '3'"
@@ -201,7 +201,7 @@ foreach(python_cmd python2 python)
endforeach(python_cmd)
if(NOT DEFINED python)
- message(FATAL_ERROR "python version 2.x (where x >= 6) required")
+ message(FATAL_ERROR "python version 2.7 required")
endif(NOT DEFINED python)
include(PiglitFindMako)