summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMircea Gherzan <mircea.gherzan@intel.com>2016-02-12 00:22:48 +0100
committerBen Widawsky <benjamin.widawsky@intel.com>2016-02-15 13:40:35 -0800
commit3b461ba02f6540b316b872c684b180dfa3095371 (patch)
tree598c333605cbf2d2d4e695bb0ab285295e6ad5e2 /CMakeLists.txt
parent671289c3775ba3a4c3ea139d754ad81b59a25791 (diff)
cmake: use the EGL_CFLAGS_OTHER
Without them, the build will fail on a system without the X headers with a recent Mesa from the master branch. The EGL_CFLAGS_OTHER define the MESA_EGL_NO_X11_HEADERS macro that guards the #includes of the X headers. Signed-off-by: Mircea Gherzan <mircea.gherzan@intel.com> Signed-off-by: Ben Widawsky <benjamin.widawsky@intel.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index d136edcad..736677fb6 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -402,6 +402,7 @@ endif()
if(EGL_FOUND)
add_definitions(-DPIGLIT_HAS_EGL)
include_directories(${EGL_INCLUDE_DIRS})
+ add_definitions (${EGL_CFLAGS_OTHER})
endif()
if(PIGLIT_BUILD_GLES1_TESTS AND NOT EGL_FOUND)