summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDylan Baker <baker.dylan.c@gmail.com>2016-01-19 15:27:20 -0800
committerDylan Baker <baker.dylan.c@gmail.com>2016-02-08 14:48:15 -0800
commit2a4fd5a83d0c588244633bee9b09f94922f91efd (patch)
treeab135a4b2f257a6aae4b58632b61c64f44197b8f /CMakeLists.txt
parent6098c203d6d8d5fcf4d4b1d3ad1332e57f6103b4 (diff)
CMake: Enable python 3.x for building
The generators have supported 3.x for some time, this now makes 3.x the default, and falls back to 2.7 This has been tested with 3.5 and 2.7 Signed-off-by: Dylan Baker <dylanx.c.baker@intel.com> Acked-by: Jose Fonseca <jfonseca@vmware.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 493cece61..b82293461 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -201,7 +201,9 @@ IF(PIGLIT_BUILD_GLX_TESTS)
pkg_check_modules(GLPROTO REQUIRED glproto)
ENDIF()
-find_package(PythonInterp 2.7 REQUIRED)
+set(Python_ADDITIONAL_VERSIONS
+ 3.5 3.4 3.3 2.7)
+find_package(PythonInterp REQUIRED)
find_package(PythonNumpy 1.6.2 REQUIRED)
find_package(PythonMako 0.8.0 REQUIRED)
find_package(PythonSix 1.4.0 REQUIRED)