summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDylan Baker <baker.dylan.c@gmail.com>2015-01-19 13:44:13 -0800
committerDylan Baker <baker.dylan.c@gmail.com>2015-01-19 14:54:22 -0800
commit2a33ddc900acd1ac9675cb9b685c326fca5ea7a8 (patch)
tree6c2ad2299faab739d9732b47fc453d73571f0da4 /CMakeLists.txt
parent25ac42dbd654daee3d5a0cf09a4212c5144eb74b (diff)
cmake: Fix ee8579b452f0 regression
Apparently find_package() and pkg_check_modules() return different variables, while piglit still builds on my system without this patch if fails on many other systems. This problem was doubly masked by the fact that in the original series there is an additional patch to use waffle's cmake config file instead of pkg_config. That patch is waiting for the next cmake release. Signed-off-by: Dylan Baker <dylanx.c.baker@intel.com> Tested-by: Mark Janes <mark.a.janes@intel.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b65f99043..b7874cf86 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -67,13 +67,13 @@ if(PIGLIT_USE_WAFFLE)
endif()
else ()
find_path(Waffle_INCLUDE_DIRS waffle.h)
- find_library(Waffle_LIBRARIES waffle-1)
- if(Waffle_INCLUDE_DIRS AND Waffle_LIBRARIES)
+ find_library(Waffle_LDFLAGS waffle-1)
+ if(Waffle_INCLUDE_DIRS AND Waffle_LDFLAGS)
set(Waffle_FOUND TRUE)
else()
message(FATAL_ERROR "Failed to find Waffle. Get and build Waffle from "
"http://www.waffle-gl.org and set Waffle_INCLUDE_DIRS and "
- "Waffle_LIBRARIES variables accordingly."
+ "Waffle_LDFLAGS variables accordingly."
)
endif()
endif ()