summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJose Fonseca <jfonseca@vmware.com>2015-02-04 20:04:37 +0000
committerJose Fonseca <jfonseca@vmware.com>2015-02-04 20:05:31 +0000
commit1dca1680c1b29cf1eb242cf8c51e157ca88c929d (patch)
tree634d4620fbf75a1f99c16319ec51e6b06f5beca9 /CMakeLists.txt
parent5c6e58ad4126abcca0407210966c14e43b26f8f2 (diff)
cmake: Fix if-command logic on non MSVC.
Trivial.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 4 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index bb1f6857c..93abb11f8 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -13,8 +13,10 @@ INCLUDE (FindPkgConfig)
project (piglit)
# Require MSVC 2013 U4
-if (${MSVC} AND ${CMAKE_C_COMPILER_VERSION} VERSION_LESS 18.00.31101.0)
- message (FATAL_ERROR "Visual Studio 2013 Update 4 or later required")
+if (MSVC)
+ if (${CMAKE_C_COMPILER_VERSION} VERSION_LESS 18.00.31101.0)
+ message (FATAL_ERROR "Visual Studio 2013 Update 4 or later required")
+ endif ()
endif ()
find_package(Threads)