summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorGurkirpal Singh <gurkirpal204@gmail.com>2018-01-20 06:14:17 +0530
committerJulien Isorce <jisorce@oblong.com>2018-03-06 14:29:42 +0000
commit83d4a5d5aea5a8a05be2eb3116d2cf3acd201876 (patch)
treef8ccf96217e9272bad9bb1e93e66d53595f34f85 /meson.build
parent430ccdbcb9155c6f3f73451047ee70f4f10f7ae5 (diff)
st/omx/tizonia: Add H.264 decoder
v2: Refactor out screen functions to st/omx Example Gstreamer pipeline : gst-launch-1.0 filesrc location=movie.mp4 ! qtdemux ! h264parse ! omxh264dec ! videoconvert ! ximagesink Acked-by: Leo Liu <leo.liu@amd.com> Reviewed-by: Julien Isorce <julien.isorce@gmail.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 2 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 6a13e80008..dd2fa60382 100644
--- a/meson.build
+++ b/meson.build
@@ -487,8 +487,10 @@ gallium_omx = _omx
dep_omx = []
dep_omx_other = []
if gallium_omx == 'bellagio'
+ pre_args += '-DENABLE_ST_OMX_BELLAGIO'
dep_omx = dependency('libomxil-bellagio')
elif gallium_omx == 'tizonia'
+ pre_args += '-DENABLE_ST_OMX_TIZONIA'
dep_omx = dependency('libtizonia', version : '>= 0.10.0')
dep_omx_other = [
dependency('libtizplatform'),