summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorEric Engestrom <eric.engestrom@imgtec.com>2018-03-23 17:18:56 +0000
committerEric Engestrom <eric.engestrom@imgtec.com>2018-03-26 09:59:32 +0100
commit1e36fe5dc490ed64736591acbcd32876ea1a69dd (patch)
treefe00bfdb496be56eaaaa023dbb0f5c321c8b3671 /meson.build
parent2f181c8c183cc8b4d0450789bb20c2be48d32db3 (diff)
meson: fix header check message
before: Checking if "endian.h works" compiles: YES after: Checking if "endian.h" compiles: YES Signed-off-by: Eric Engestrom <eric.engestrom@imgtec.com> Reviewed-by: Emil Velikov <emil.velikov@collabora.co.uk>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 041d2bfc70..f210eeb253 100644
--- a/meson.build
+++ b/meson.build
@@ -917,7 +917,7 @@ elif cc.has_header_symbol('sys/mkdev.h', 'major')
endif
foreach h : ['xlocale.h', 'sys/sysctl.h', 'linux/futex.h', 'endian.h']
- if cc.compiles('#include <@0@>'.format(h), name : '@0@ works'.format(h))
+ if cc.compiles('#include <@0@>'.format(h), name : '@0@'.format(h))
pre_args += '-DHAVE_@0@'.format(h.to_upper().underscorify())
endif
endforeach