summaryrefslogtreecommitdiff
path: root/bin/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'bin/Makefile.am')
-rw-r--r--bin/Makefile.am11
1 files changed, 8 insertions, 3 deletions
diff --git a/bin/Makefile.am b/bin/Makefile.am
index 24e77b41..91fc956a 100644
--- a/bin/Makefile.am
+++ b/bin/Makefile.am
@@ -22,12 +22,13 @@ AM_CPPFLAGS = \
-I$(top_srcdir)/gegl/property-types
AM_CFLAGS = \
- $(DEP_CFLAGS) $(BABL_CFLAGS) $(PNG_CFLAGS)
-
+ $(DEP_CFLAGS) $(BABL_CFLAGS) $(PNG_CFLAGS) \
+ $(MRG_CFLAGS) $(GEXIV2_CFLAGS)
AM_LDFLAGS = \
$(no_undefined) ../gegl/libgegl-$(GEGL_API_VERSION).la \
- $(DEP_LIBS) $(BABL_LIBS) $(PNG_LIBS) $(LIBSPIRO) $(MATH_LIB)
+ $(DEP_LIBS) $(BABL_LIBS) $(PNG_LIBS) $(LIBSPIRO) $(MATH_LIB) \
+ $(MRG_LIBS) $(GEXIV2_LIBS)
bin_PROGRAMS = gegl gegl-tester
@@ -41,6 +42,10 @@ gegl_SOURCES = \
gegl_tester_SOURCES = \
gegl-tester.c
+if HAVE_MRG
+gegl_SOURCES += mrg-ui.c
+endif
+
if HAVE_SPIRO
gegl_SOURCES += gegl-path-spiro.h gegl-path-spiro.c
endif