summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorØyvind Kolås <ok@src.gnome.org>2008-05-17 13:39:53 +0000
committerØyvind Kolås <ok@src.gnome.org>2008-05-17 13:39:53 +0000
commit8aeab06381d4778021c28a4004aaa2e04df291e9 (patch)
tree728df8540c1a1007bbe7bb0b17468d2a92bf2924 /Makefile.am
parentc739203a636d6082657bf302c6fc36b6a8075c7d (diff)
added examples subdir. added examples/Makefile.am new dir. added a make
* Makefile.am: added examples subdir. * configure.ac: added examples/Makefile.am * examples/: new dir. * examples/Makefile.am: added a make file with wildcards that builds, dists and cleans .c files, each .c file in the dir turns into an executable. * examples/gegl-paint.c: a tiny drawing app. svn path=/trunk/; revision=2299
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am11
1 files changed, 8 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 2e24ce93..0404821b 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,11 +1,16 @@
AUTOMAKE_OPTIONS = dist-bzip2
-SUBDIRS= gegl operations bin tools
+SUBDIRS=\
+ gegl \
+ operations \
+ bin \
+ tools \
+ examples
+
if ENABLE_DOCS
SUBDIRS+= docs
endif
-
pkgconfigdir = $(libdir)/pkgconfig
pkgconfig_DATA = gegl.pc
@@ -34,4 +39,4 @@ endif
dist-hook: dist-check-w3m
website: all
- $(MAKE) -C docs website
+ $(MAKE) -C docs website \ No newline at end of file