summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorØyvind Kolås <ok@src.gnome.org>2006-08-22 22:09:26 +0000
committerØyvind Kolås <ok@src.gnome.org>2006-08-22 22:09:26 +0000
commit824d993c92e804c5ec55f531f888a8019f0e3556 (patch)
treeb08c0209e7eea5dea465fdab2ec449b7e408998c /Makefile.am
parent885a7a4f75156fb621d9c8b65e410293888f6e99 (diff)
generate README from html
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am13
1 files changed, 13 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index b0a032b2..ede2bd59 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -8,3 +8,16 @@ EXTRA_DIST = \
pkgconfigdir = $(libdir)/pkgconfig
pkgconfig_DATA = gegl.pc
+
+built_dist_files = README
+if HAVE_W3M
+dist-check-w3m:
+
+README: docs/index.html
+ $(W3M) -cols 72 -dump $< > $@
+else
+dist-check-w3m:
+ @echo "*** w3m must be available in order to make dist"
+ @false
+endif
+