summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorZhigang Gong <zhigang.gong@linux.intel.com>2013-07-08 17:36:45 +0800
committerZhigang Gong <zhigang.gong@linux.intel.com>2013-07-12 09:42:37 +0800
commit46fadccdb12a6bb092f4c335325aba5d083727f7 (patch)
treedc06d7697c2d7923a2fd2d335a74ac62b47a0878 /CMakeLists.txt
parent1a9d0ce64086bd6fef2ec9fd6c79e6074cd35d13 (diff)
CL: Refine the version string handling.
Now concentrate the version assignment at the root cmake files. All the other place will refer the specified macros other than hard coded a number. Signed-off-by: Zhigang Gong <zhigang.gong@linux.intel.com> Reviewed-by: Song, Ruiling <ruiling.song@intel.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 4 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 41ac43be..11b1794d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -8,8 +8,10 @@
CMAKE_MINIMUM_REQUIRED(VERSION 2.6.0)
PROJECT(OCL)
-set (LIBCL_VERSION_MAJOR 0)
-set (LIBCL_VERSION_MINOR 2)
+set (LIBCL_DRIVER_VERSION_MAJOR 0)
+set (LIBCL_DRIVER_VERSION_MINOR 2)
+set (LIBCL_C_VERSION_MAJOR 1)
+set (LIBCL_C_VERSION_MINOR 1)
configure_file (
"src/OCLConfig.h.in"