summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index e066b3dc..d54c0d50 100644
--- a/configure.ac
+++ b/configure.ac
@@ -133,6 +133,11 @@ if test "$KMS_ONLY" = yes; then
AC_DEFINE(KMS_ONLY,1,[Assume KMS support])
fi
+# FIXME: Write some clever check here.
+AC_DEFINE(XORG_HOSTED, 1, [Enable wayland integration.])
+AM_CONDITIONAL(XORG_HOSTED, true)
+PKG_CHECK_MODULES(WAYLAND, [wayland-client])
+
DRIVER_NAME=intel
AC_SUBST([DRIVER_NAME])
AC_SUBST([moduledir])