summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJesse Barnes <jbarnes@virtuousgeek.org>2009-08-25 09:46:10 -0700
committerJesse Barnes <jbarnes@virtuousgeek.org>2009-08-25 09:48:10 -0700
commit1fc3f467ab3edd405adc569ac7f629077e6ffb9d (patch)
treefd911840f307db28bc773e161c85e8092e12b200 /configure.ac
parent5dccd1be3ab80b642ef2022446f5bdc1656ed943 (diff)
Add KMS only build flag
Rather than refactoring all our init code only to have it go away when we remove UMS, this patch adds a build time flag to allow the driver to assume KMS support. With this flag active, the driver will not request that I/O or MEM be enabled at probe time, which can allow the server (if other drivers also cooperate) to run as a non-root user. Signed-off-by: Jesse Barnes <jbarnes@virtuousgeek.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index d5c12a8d..54560bc3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -83,6 +83,11 @@ AC_ARG_ENABLE(xvmc, AC_HELP_STRING([--disable-xvmc],
[XVMC="$enableval"],
[XVMC=yes])
+AC_ARG_ENABLE(kms-only, AC_HELP_STRING([--enable-kms-only],
+ [Assume KMS support [[default=no]]]),
+ [KMS_ONLY="$enableval"],
+ [KMS_ONLY=no])
+
# Checks for extensions
XORG_DRIVER_CHECK_EXT(XINERAMA, xineramaproto)
XORG_DRIVER_CHECK_EXT(RANDR, randrproto)
@@ -166,6 +171,11 @@ if test "$XVMC" = yes; then
AC_SUBST([XVMCLIB_CFLAGS])
fi
+AM_CONDITIONAL(KMS_ONLY, test x$KMS_ONLY = xyes)
+if test "$KMS_ONLY" = yes; then
+ AC_DEFINE(KMS_ONLY,1,[Assume KMS support])
+fi
+
AC_SUBST([DRI_CFLAGS])
AC_SUBST([XORG_CFLAGS])
AC_SUBST([WARN_CFLAGS])