summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAnder Conselvan de Oliveira <ander.conselvan.de.oliveira@intel.com>2012-06-08 11:58:02 +0300
committerKristian Høgsberg <krh@bitplanet.net>2012-06-08 12:50:42 -0400
commitdd8891be36ec208a5e8e5dd32c32426713f16877 (patch)
tree0b8f8b81dec11c6bc279770f9c8c0f991b783a62 /configure.ac
parentc29020332a7bb56cb9e5c5928ed9a5a2e80b2bef (diff)
wayland-cursor: add an option that changes the cursor theme directory
Some distros (e.g. gentoo) install cursor themes in non-standard directories. Add option --with-icondir to configure.sh that sets the directory in which to look for cursors.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index a682c9a..d78a82d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -55,6 +55,11 @@ AC_ARG_ENABLE([documentation],
AM_CONDITIONAL(ENABLE_SCANNER, test "x$enable_scanner" = xyes)
+AC_ARG_WITH(icondir, [ --with-icondir=<dir> Look for cursor icons here],
+ [ ICONDIR=$withval],
+ [ ICONDIR=${datadir}/icons])
+AC_SUBST([ICONDIR])
+
EXPAT_LIB=""
AC_ARG_WITH(expat, [ --with-expat=<dir> Use expat from here],
[ expat=$withval