summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorKristian Høgsberg <krh@bitplanet.net>2013-04-03 16:22:44 -0400
committerKristian Høgsberg <krh@bitplanet.net>2013-04-03 16:22:44 -0400
commitc42b09b4cb36d9d169483b934a7f4abe91f7b0ce (patch)
treec0e7902313de31c6f7a8788f8ba3d1fa2c70bbee /configure.ac
parent9d296fc73a81931b4c02b789b3c488861dbf3fda (diff)
configure.ac: Fix publican version check
This sure is ugly - we feed output of publican -v into bc to compare against minimum required version, 2.8. That's bad enough, but when publican suddenly report 3.0.0, bc starts complaining... Use sed to filter out 3.0 from the 'version=3.0.0' output from publican instead. Seem a little more robust, but it's just a matter of time before something else breaks this flaky setup. Hey, publican, how about shipping .pc files?
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index db0855e..4271c7a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -101,7 +101,7 @@ if test "x$enable_documentation" = "xyes"; then
AC_PATH_PROG(PUBLICAN, publican)
if test "x$PUBLICAN" != "x"; then
- PUBLICAN_VERSION=`$PUBLICAN -v | cut -d'=' -f2`
+ PUBLICAN_VERSION=[`$PUBLICAN -v | sed -e 's/version=\([0-9]*\.[0-9]*\).*/\1/'`]
if test [ 1 -eq `echo "${PUBLICAN_VERSION} < 2.8" | bc` ]; then
AC_MSG_ERROR([Publican version is not supported. Install publican >= 2.8 or disable the documentation using --disable-documentation])