summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorjani.uusi-rantala@nokia.com <jani.uusi-rantala@nokia.com>2011-05-06 06:13:36 +0000
committerKristian Høgsberg <krh@bitplanet.net>2011-05-06 17:35:23 -0400
commit53200f05c7682de3c4a2d061512b2989b6a3fd6f (patch)
tree84e6160050e98cbf081417024572bec348e8e195 /configure.ac
parentbd70dc185a643f739f80a09e860b7a81bbb57272 (diff)
Add configure option to disable scanner compilation
When cross-compiling Wayland, wayland-scanner should be picked up from the host system instead of compiling and trying to run e.g. ARM wayland-scanner on X86. This patch adds --disable-scanner option for disabling the scanner from the build and using existing wayland-scanner instead (from PATH) which should help in most cross-compilation systems. By default everything works as before. Signed-off-by: Jani Uusi-Rantala <jani.uusi-rantala@nokia.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 34b8dbc..7dc8ccb 100644
--- a/configure.ac
+++ b/configure.ac
@@ -27,6 +27,14 @@ if test "x$GCC" = "xyes"; then
fi
AC_SUBST(GCC_CFLAGS)
+AC_ARG_ENABLE([scanner],
+ [AC_HELP_STRING([--disable-scanner],
+ [Disable compilation of wayland-scannner])],
+ [],
+ [enable_scanner=yes])
+
+AM_CONDITIONAL(ENABLE_SCANNER, test "x$enable_scanner" = xyes)
+
EXPAT_LIB=""
AC_ARG_WITH(expat, [ --with-expat=<dir> Use expat from here],
[ expat=$withval