summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTiago Vignatti <tiago.vignatti@intel.com>2012-10-12 20:54:45 +0300
committerKristian Høgsberg <krh@bitplanet.net>2012-10-15 13:10:08 -0400
commit008760822b973ff1f8122533787a4dadeed7e2a8 (patch)
treec185575df7ea1b058a286c698c19c2791b5dcbb1 /configure.ac
parent96a6ee58b96afc51a78859fe6da0d9b015a68cc9 (diff)
configure: Make documentation option work in fact
Also, now doxygen is mandatory for building the documentation (looks reasonable because both man-pages and publican will need it). Signed-off-by: Tiago Vignatti <tiago.vignatti@intel.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 8 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 860d715..c4e1f63 100644
--- a/configure.ac
+++ b/configure.ac
@@ -43,7 +43,7 @@ AC_CHECK_FUNCS([accept4 mkostemp])
AC_ARG_ENABLE([scanner],
[AC_HELP_STRING([--disable-scanner],
- [Disable compilation of wayland-scannner])],
+ [Disable compilation of wayland-scanner])],
[],
[enable_scanner=yes])
@@ -76,7 +76,14 @@ fi
AC_PATH_PROG(XSLTPROC, xsltproc)
AM_CONDITIONAL([HAVE_XSLTPROC], [test "x$XSLTPROC" != "x"])
+AM_CONDITIONAL(BUILD_DOCS, [test x$enable_documentation = xyes])
if test "x$enable_documentation" = "xyes"; then
+ AC_PATH_PROG(DOXYGEN, doxygen)
+
+ if test "x$DOXYGEN" = "x"; then
+ AC_MSG_ERROR([Documentation build requested but doxygen not found. Install doxygen or disable the documentation using --disable-documentation])
+ fi
+
AC_PATH_PROG(PUBLICAN, publican)
AC_CONFIG_FILES([