summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGwenole Beauchesne <gwenole.beauchesne@intel.com>2012-01-30 18:25:03 +0100
committerGwenole Beauchesne <gwenole.beauchesne@intel.com>2012-01-30 19:53:13 +0100
commitb54bf3175c0dde840902f47bbbc63422fe136fe7 (patch)
tree11bdbab1a2f45f541cafcc4d27e05c9b6d4363e5 /configure.ac
parent0fb1147d9c254cf529199b87b4dc9892545da2dd (diff)
Add glib compatibility glue for older versions.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 9a5ff84..1d4e343 100644
--- a/configure.ac
+++ b/configure.ac
@@ -147,6 +147,9 @@ AC_SUBST(GTKDOC_VERSION)
dnl Check for GLib
AC_PATH_PROG([GLIB_GENMARSHAL], [glib-genmarshal])
PKG_CHECK_MODULES([GLIB], [glib-2.0])
+AC_CHECK_LIB([glib-2.0], [g_list_free_full], [
+ AC_DEFINE([HAVE_G_LIST_FREE_FULL], [1],
+ [Define to 1 if g_list_free_full() is available.])])
AC_SUBST(GLIB_CFLAGS)
AC_SUBST(GLIB_LIBS)