summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGwenole Beauchesne <gwenole.beauchesne@intel.com>2012-07-23 17:54:58 +0200
committerGwenole Beauchesne <gwenole.beauchesne@intel.com>2012-07-24 15:57:57 +0200
commit96040a0fa2f96eb473b84f16309dac90e0f2bd84 (patch)
tree2cafc0cee9db73a154390c1a78ee694c27caf774 /configure.ac
parent8f132b79363d5bf9a1d00753bdb61fe504372cda (diff)
configure: simplify video outputs summary.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 5 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index b3a26ef..7ef92f3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -453,11 +453,13 @@ yesno() {
test $1 -eq 1 && echo yes || echo no
}
+VIDEO_OUTPUTS=""
+AS_IF([test $USE_X11 -eq 1], [VIDEO_OUTPUTS="$VIDEO_OUTPUTS x11"])
+AS_IF([test $USE_GLX -eq 1], [VIDEO_OUTPUTS="$VIDEO_OUTPUTS glx"])
+
echo
echo $PACKAGE configuration summary:
echo
echo VA-API version ................... : $VA_VERSION_STR
-echo GLX support ...................... : $(yesno $USE_GLX)
-echo VA/X11 support ................... : $(yesno $USE_X11)
-echo VA/GLX support ................... : $(yesno $HAVE_VA_GLX)
+echo Video outputs .................... : $VIDEO_OUTPUTS
echo