summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorgb <gb@5584edef-b1fe-4b99-b61b-dd2bab72e969>2010-03-16 13:53:09 +0000
committergb <gb@5584edef-b1fe-4b99-b61b-dd2bab72e969>2010-03-16 13:53:09 +0000
commit4a041f42c1e842f4fe4dedb54887e2b65f7777f9 (patch)
tree3af23d3c1a68f755e26315cef42bc776f7138990 /Makefile.am
parent2041c8ca257f89569c3d25bd97602c511ff908a9 (diff)
Add debian packaging.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 7 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 6f73729..99d568d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,9 +1,15 @@
AUTOMAKE_OPTIONS = foreign
-SUBDIRS = gst-libs pkgconfig sys tests
+SUBDIRS = debian gst-libs pkgconfig sys tests
# Extra clean files so that maintainer-clean removes *everything*
MAINTAINERCLEANFILES = \
aclocal.m4 compile config.guess config.sub \
configure depcomp install-sh ltmain.sh \
Makefile.in missing config.h.in
+
+deb: dist
+ -mkdir -p debian-build
+ cd debian-build && \
+ tar zxvf ../$(PACKAGE)-$(VERSION).tar.gz && \
+ cd $(PACKAGE)-$(VERSION) && dpkg-buildpackage -rfakeroot -uc -us