summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 51cb8e8..2459047 100644
--- a/configure.ac
+++ b/configure.ac
@@ -22,6 +22,12 @@ AC_CHECK_HEADER(boost/shared_ptr.hpp, [],
[AC_MSG_ERROR(boost/shared_ptr.hpp not found. install boost)], [])
AC_LANG_RESTORE
+AC_PATH_PROG(PYTHON, python)
+if test -z "PYTHON"; then
+ AC_MSG_ERROR([python not found in your path.])
+fi
+AC_SUBST(PYTHON)
+
ROOTDIR=`pwd`
AC_SUBST(ROOTDIR)