summaryrefslogtreecommitdiff
path: root/cmake/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'cmake/CMakeLists.txt')
-rw-r--r--cmake/CMakeLists.txt7
1 files changed, 6 insertions, 1 deletions
diff --git a/cmake/CMakeLists.txt b/cmake/CMakeLists.txt
index 5ba0bf6..e7a6552 100644
--- a/cmake/CMakeLists.txt
+++ b/cmake/CMakeLists.txt
@@ -24,7 +24,12 @@ set(CMAKE_C_FLAGS_DEBUG "-g -Wall")
set(CMAKE_CXX_FLAGS_DEBUG "-g -Wall")
set(CMAKE_SHARED_LINKER_FLAGS "-shared -Wl,-soname,${SHARED_LIB_NAME} -Wl,--no-undefined")
-set(SRC_FILES ../source/dpsource.cxx ../source/dpdimensions.cxx)
+# Source files to build.
+set(SRC_FILES
+ ../source/dpsource.cxx
+ ../source/dpdimensions.cxx
+ ../source/dpdimension.cxx
+)
add_library(${TARGET_NAME} SHARED ${SRC_FILES})
target_link_libraries(${TARGET_NAME} uno_cppuhelpergcc3 uno_sal uno_cppu)