summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJamey Sharp <jamey@minilop.net>2011-09-13 17:45:19 -0500
committerJamey Sharp <jamey@minilop.net>2011-09-15 10:11:43 -0500
commit6ad7bb69eebd5e5b4068bd9aa0b9a7168f075006 (patch)
tree308c3b0932e22a5f6797d22e1e3358c5387722fb /configure.ac
parent9eb22ebf46b77c15e53017a37c7ef605521dc164 (diff)
Remove PC98 support.
Gaetan Nadon wrote: Alan Coopersmith wrote: "I think we recently dropped PC98 support from the X server, so I'd be okay with dropping the documentation now". Let's make them be right, shall we? Signed-off-by: Jamey Sharp <jamey@minilop.net> Reviewed-by: Jeremy Huddleston <jeremyhu@apple.com> Acked-by: Gaetan Nadon <memsize@videotron.ca> Acked-by: Alan Coopersmith <alan.coopersmith@oracle.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 0 insertions, 15 deletions
diff --git a/configure.ac b/configure.ac
index 6c4fffda1..93cd6a96f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -582,9 +582,6 @@ AC_ARG_ENABLE(install-libxf86config,
AC_ARG_ENABLE(visibility, AC_HELP_STRING([--enable-visibility], [Enable symbol visibility (default: auto)]),
[SYMBOL_VISIBILITY=$enableval],
[SYMBOL_VISIBILITY=auto])
-AC_ARG_ENABLE(pc98, AC_HELP_STRING([--enable-pc98], [Enable PC98 support in Xorg (default: auto)]),
- [SUPPORT_PC98=$enableval],
- [SUPPORT_PC98=auto])
dnl GLX build options
AC_ARG_ENABLE(aiglx, AS_HELP_STRING([--enable-aiglx], [Build accelerated indirect GLX (default: enabled)]),
@@ -1654,9 +1651,6 @@ if test "x$XORG" = xyes; then
XORG_CFLAGS="${XORG_CFLAGS} "'$(SOLARIS_ASM_CFLAGS)'
fi
AC_SUBST([SOLARIS_ASM_CFLAGS])
- if test "x$SUPPORT_PC98" = xauto; then
- SUPPORT_PC98="no"
- fi
;;
gnu*)
XORG_OS_SUBDIR="hurd"
@@ -1679,18 +1673,9 @@ if test "x$XORG" = xyes; then
xorg_bus_sparc="yes"
;;
i*86)
- if test "x$SUPPORT_PC98" = xauto; then
- SUPPORT_PC98="yes"
- fi
;;
esac
- if test "x$SUPPORT_PC98" = xauto; then
- SUPPORT_PC98="no"
- fi
- if test "x$SUPPORT_PC98" = xyes; then
- AC_DEFINE(SUPPORT_PC98, 1, [Support PC98])
- fi
if test "x$DGA" = xauto; then
PKG_CHECK_MODULES(DGA, $DGAPROTO, [DGA=yes], [DGA=no])
fi